How can I stop linkage between two icons

Can you please help in finding, if I can stop the linking through the connection points?
The arrow should not appear if I click on the the connection port.

Do you mean you don’t want the LinkingTool to automatically start when dragging from a port?

You can either disable the LinkingTool, or if you want to be more specific, set fromLinkable/toLinkable on the ports. But the default value for those properties on ports is false – you must have set one or both to true for this behavior to be happening.

Thanks @jhardy, it worked.