JGo 4 compatibility with Java 1.3 and 1.4

We are using an older version (4/4.1) of JGo. Just wondering if this is ‘officially’ compatible with both Java 1.3 and Java 1.4?

Yes, it is.
All versions of JGo for Swing (>= 2.0) should work with all versions of Swing (>= 1.2). However, a while ago [I don’t remember exactly when] we did change our example applications to depend on JRE 1.4 or later. But even those examples could be easily modified to run on JRE 1.3 by commenting out some of the example code.
As a practical matter, though, we no longer test JGo with any JRE < 1.4.2.
For fun I just tried running some of the JGo 4.0.4 example JARs with JRE 6.0. They worked fine, although I can see how much better JGo has become since JGo 4.0. Version 4.0 was released in March of 2001!

Thanks. What about Java 5? Is that compatible with JGo 4/4.1?

Again - many thanks!


Yes, as far as I know. Again, I don’t think we have tested them, since 4.0 (2001) and 4.1 (2002) are so old.
If you are in the process of doing new development on an old project, I recommend at least considering upgrading to a newer version of JGo.