Licensing error with GoView

I am building a xbap application that uses a GoView to show diagramms in our ie export for our customers.
In order to access the GoView I added a reference to the northwoods.go.dll and added the goview to WindowsFormHost on my wpf page using latebinding like this:
<Page x:Class="Page1" xmlns="" xmlns:x="" xmlns:go="clr-namespace:Northwoods.Go;assembly=Northwoods.Go" Width="Auto" Height="Auto">
<WindowsFormsHost Name="WindowsFormsHost1"> <go:GoView Name="myGoV"></go:GoView> </WindowsFormsHost>
Everything works fine on my machine, but I am not able to launch my xbap on a client/customer machine because of a licensing error.
What I have done:
1. Deploying my xbap
2. installing the northwoods.go.dll and northwoods.go.xml.dll to the gac of the client machine
3. Double click the xbap and than a licencing error occurs.
I already checked the licenses.licx. It was empty because I added the goview dynamicly (see above). So I added Northwoods.Go.GoView, Northwoods.Go, Version=, Culture=neutral, PublicKeyToken=a4e3b7b70161cfe8 manually. and tried again with the same result.
It is really important for me to find a solution for this!
Thank you for help!

You need to make sure the version number in the LICENSES.LICX file is correct. In this case, you need to say instead of!

You probably do not need to install any DLLs into the client machine’s Global Assembly Cache. Do you require full trust?

Hi walter,

yes I had the right version number in my licx ( not the It was a mistake in my post.
The xbap requires to install all linked dlls that are not part of the .net-framework to install in the gac. Therefore I installed it to the gac.
My xbap also requires full trust.
Is the problem may be related to the issue that I do not have a real exe file?

Well, if you built an XBAP, you do have a real EXE file.

What’s the error message?

Does the client machine have .NET 3.5 installed?

The error message is:

MS .NET Framework 3.5 SP1 is installed.

This might be a bug in WPF, but I thought Microsoft had fixed it for 3.5. Perhaps that fix did not make it into the 3.0 DLLs, which you seem to be using. We’ll need to investigate further.

Can I help you investigating? May be send you a demo app?

hi walter,

thank you for your mail. I wanted to download the replacement DLLs but the link mentioned in the word document "SpecialDeployments" don't work.
Maybe you can send me another link or replacemnet dll directly via mail.
Thank you for your quick support!

Did you replace MNBV with the version number you are using?

sorry! of course not… I should read the text more carefully. The download works

Thank you Walter and Jake,

solution 1 mentioned in the word worked perfect!
Thank you very much!