Location of go.licenseKey


#1

Hi,

I m working in a browser with the 1.8.32 version.

I have the go license and put it after the go library and before define the first diagram. But the watermark still there.

Do we need internet connection or something like that?


#2

If you are asking whether the GoJS library requires an internet connection to our server, the answer is NO. It never “phones home”, so it never needs any internet connection. Unless you ask it to load some image from some URL that requires an external internet connection, of course.

Is your HTML page being served from localhost or from the domain defined in the license key?


#3

From localhost


#4

I’m not sure. Could you check in the debugger that the go.js library that the page is loading is really version 1.8.32 (or any 1.8.* version – the baselevel doesn’t matter)? I’m concerned that you might be unintentionally loading an old version. Just look at the first lines of the JS file in the debugger. Or evaluate go.version.

And I suppose you also might want to confirm that the value of go.licenseKey is the same long string that our server sent you.


#5

Yeah, the version is 1.8.32.

I put scripts with this order in my main.html

   <script src="go.js"> //We have the source code
  <script>go.licenseKey = xxxxxxxxx</script>
  //A lot of libraries and tools more
  <script src="main.js">//Where we make all diagrams

Is the correct order?


#6

Your HTML is invalid, so you are not executing that go.licenseKey assignment.

Every script tag must have a closing tag. Note how they are colored. https://developer.mozilla.org/en-US/docs/Web/HTML/Element/script


#7

Yeah we have code with closing tags, i put that like example case.

So, with closing tags the code is correct , right?


#8

If the closing tags match, yes. It’s a holiday today on a long holiday weekend, so we will investigate the bug on Monday. In the meantime you can continue to use the go.js or go-debug.js library file that you have gotten from GitHub or npm or downloaded in our site.zip file.


#9

Ah, it turns out that the behavior is as intended – when using the source code if you haven’t minified the code, it continues to show a watermark.


#10

We tried the minified version and we have the same problem


#11

This is surprising. I know that other customers do not have this problem, so I’m wondering if there is a way for you to let us examine the minified code. You can send us email to our product name at nwoods.com.


#12

Well, we tried the codificated version of the library as “minified” code. But our ap still have the watermark


#13

What do you mean by “codificated”? What tools and build procedure are you using?