Printing GoDiagram from using explorer


We are using version of GoDiagram (v4.0.0.2) with web site in .net v2.0 and are experiencing a weird problem when users are trying to print the page hosting the godiagram from internet explorer.

The problem is as follows:

1. Printing the page from the dev.environment (when browsing the local host) works fine.

2. Printing the page from a different computer - ie not from localhost - shows the box of the image but with a red X on it + the text: Loading…GoWebImage.axs

3. Printing from Chrome or Firefox works fine.

Does anyone ever have this problem? do you know how it can be solved? this is an urgent production issue that we have and can’t solve so any help will be appreciated.



What version of IE?

Can you reproduce the problem with any of the sample apps?

It is happening with IE7,8 - also in the print preview, but i bet it happens in others as well. I have found a workaround though:

1. Since it is working when browsing to the localhost but not when browsing from the outside to the same computer, i guess it has to do with security.

2. so, i tried adding the computer to the “trusted sites” in my internet explorer and voila it works.

I am not sure if this workaround is enough for everyone but it might be ok for me since my customers are not anonymous internet users but rather intranet ones.

In any case i think it has to do with how IE treats requests to .AXD handlers when generating prints or so and it doesnt allow something that happens there… that’s my 2 cents. Maybe someone will be able to dig in deeper. I would be happy to assist with any attempts to fix this. I will try this with the sample apps on the site and let you know.

I’m wondering if it is something about the way you have IE configured… I don’t recall ever seeing this before.

go to

and use the Print… button there and see if you have the same problem. Then, try another PC or 2 in your office to see what they do…

Are you doing cross-domain or https or something more “interesting” than a vanilla ASP.NET app?


I noticed all of your demo sites work + the demo link you sent me. So its not my IE but rather something on my application.

Regarding Special things: We do have HTTPS on the production site but i can make this happen on my non-HTTPS dev computer too the moment i try to browse to it from a different computer and not locally. I will try to pinpoint the problem with a test application. Thanks for the response.