Scroll bar

I overrode GoView.OnKeyDown to move the GoNodes using the keyboard arow keys. I call DoMove to the new location.
When I move the objects to the left of the screen, it keeps moving and a scroll bar appears in the view.
I want it to stop scrolling at the left bounds of the view, and only make the view expands from the right.

You probably want to set GoView.ShowsNegativeCoordinates to false.
That won’t keep the selected objects from moving into negative coordinates, but will keep the view from scrolling there. The easiest way to limit moves, such as not beyond a certain location, is to override GoObject.ComputeMove on your node class(es). The LimitedNode example class in Demo1 does this, for example.
By the way, in version 2.4, you can turn on the ability of GoView to have the arrow keys move the current selection, as follows:
goView1.DisableKeys &= ~GoViewDisableKeys.ArrowMove;
Or if you want to turn on all GoView default key command behavior, just set GoView.DisableKeys to GoViewDisableKeys.None.