Setting up JGo with Eclipse Plugin

I have an Eclipse plugin which throws java.lang.NoClassDefFoundError: com/nwoods/jgo/JGoView on the following line: JGoView jgoView = new JGoView(parent, 0);

Everything compiles. I’ve tried copying JGoSWT.jar from the install directory to the root directory of my plugin, but I still get this error.

I’m missing something trivial. But what?

FWIW I can compile and run com.nwoods.jgo.examples.MinimalApp in my own project just fine, just can’t execute my plugin.

Thank you,

my .classpath:

<?xml version="1.0" encoding="UTF-8"?> <classpath> <classpathentry kind="src" path="src"/> <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/> <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/> <classpathentry kind="lib" path="C:/JGoSWT5.1Eval/JGoSWT.jar"/> <classpathentry kind="output" path="bin"/> </classpath>

My Java Build Path settings:

You’re certainly right to be focusing on class path. It’s definately a configuration issue - it obviously can’t find the class definitions for JGo. Unfortunately, I’m not sufficiently familiar with Eclipse plug-ins to see why your classpath definitions isn’t working. Any Eclipse pros out there???

  • Scott

It’s amazing the stupid stuff that you can spend 4 hours on troubleshooting one day, then come in the next day refreshed and fix in 5 minutes.

For closure, there seems to be a bug in Eclipse where you can’t pass in a fully qualified library - you have to pass it in relative to the current directory. I guess I have to make a local copy of JGoSWT.jar to put in my plugin root. Oh well.