Shift-Delete Cut

I noticed that Shift-Delete doesn’t perform a ‘Cut’ as it does in applications such as Visio. At least it doesn’t do that by default. Is there some property or something I have to set? If not, what is the best way to handle it?

Which sample? I just tried 3 at random, and Shift-Del worked in all 3.

I used Basic App sample. I held shift while I pressed the delete key. I then tried to ctrl-v and nothing happend. When I do a ctrl-x and then ctrl-v, it is pasted back.

OH! sorry. I was just looking at the delete behavior, not the clipboard. Actually, it does look like we intended Shift-Del to be a Cut…

gotta go watch my son play baseball, but I’ll take a look at this later tonight.

Yes, it looks like we check for Del before we check for Shift-Del… truly amazing no one else has ever noticed this.

We can probably get this into 4.1, which is ready to ship except for problems with a new doc tool we’re using.

Do you need a workaround for the current version?

Honestly, I didn’t even know shift-delete did that till the boss was looking for it. I think we can wait until 4.1. I’ll post again to this thread if that changes.

Thanks for looking into it.