Sticky Orthogonal Links Needed

I have just started evaluation GoDiagram. For my project I will only use GoTextNodes with two ports, one on the left and one on the right. The left port will only allow incomming links and the right port will only allow outgoing links. The links will be orthogonal and AvoidsNodes will be true. The links are movable allowing the user to manually move them around nodes how the user wants. The problem is when a node is moved, the links recalculate completely, ignoring where the user moved the segments.
I think what I want can be stated like this. When moving a node, only the two segments nearest the node will stretch. For example, if the node is moved horizontally, the segment attached to the node (ports only on left and right) will stretch. The other segments will not move. If the node is moved vertically, the second segment (the first one that is vertical) will stretch.
Looking at the API, I thought this would have something to do with GoLink.AdjustingStyle. However none of the values seem to provide the effect I am looking for.
How can I accomplish this?

Ah, the problem is that the GoLink.AvoidsNodes property is taking precedence over other properties such as GoLink.AdjustingStyle. That’s because when AvoidsNodes is true, the routing is completely controlled by that algorithm. After all, one can’t maintain the requirement of having a link avoid nodes if it could only modify the last two segments of the route.
Perhaps you can get the effect you want by setting AvoidsNodes to true only when you know it’s OK to have a completely new route, and leaving it false the rest of the time.
A few comments that might be helpful: Setting AvoidsNodes to false will not change the route, but setting it to true may very well do so. A true value for AvoidsNodes doesn’t do any good until the link is part of the document, since otherwise it wouldn’t know which nodes to try to avoid. I assume you know about setting properties on the GoView.NewLinkPrototype in order to specify them for all newly drawn links in that view.

Thanks, that explains it perfectly. I turned off the AvoidsNodes property. I am ok with the initial layout crossing nodes since the user will likely move the link around anyway.