Trouble Configuring License with Deployment

I’m having trouble configuring my project for deployment. Here’s a short description of my situation:

Using Visual Studio 2010
Targeting .NET 4
Developing Windows Form app
Using the Northwoods.Go dll, version

I got the license manager installed fine. I was able to develop my application without a hitch (one of my win forms uses the GoView control). Now it’s time for deployment. I’ve got the licenses.licx file in my project. Right now, that file is set to copy to the output folder, so it’s present at execution. I also used the Visual Studio license compiler to create the licenses file. This is also copied into the output folder and present during execution.

How should I configure the build action for these two files? I’m not particularly sure.

I can run the application fine on my machine, where the developer license is installed. However, once I move it to another machine (without the dev license), it can’t find my licx or the complied license files. It throws this exception:

license exception

Is there something I’m doing wrong? What am I missing? Thanks for any help.

Run the License Manager and make sure you have a development license activated.

Compare your licenses.licx file to the one in the MinimalApp sample.

Well that’s strange. In the samples, the dlls are all version

However the licenses.licx files in the sample projects all show version

The licenses.licx that was generated in my project has for the version number.

I have tried to use the Visual Studio license compiler (lc command) on both the MinimalApp and my project and neither deploy correctly. They both state the license is invalid or expired (the same exception shown above).

My development license is still fine, because everything works on my machine. Is there a specific way I need to arrange my executable and .licx file before running the Visual Studio license compiler?

The last 2 digits don’t matter to the licensing.

email me a screenshot of your license manager. You can have an eval license that makes things look ok on your system, but don’t allow you to deploy.

This problem has been solved with Jake’s help.

The issue seemed to stem from Visual Studio creating an incomplete licenses.licx file. Originally when I dropped that GoView control onto my form and it auto-generated the licenses.licx file, the contents were as follows:

Northwoods.Go.GoView, Northwoods.Go, Version=, Culture=neutral, PublicKeyToken=a4e3b7b70161cfe8

Apparently, the GoView control uses other controls that need to be included into the licenses.licx file. I change the contents of the file to this:

Northwoods.Go.GoView, Northwoods.Go, Version=, Culture=neutral, PublicKeyToken=a4e3b7b70161cfe8
Northwoods.Go.GoPalette, Northwoods.Go, Version=, Culture=neutral, PublicKeyToken=a4e3b7b70161cfe8
Northwoods.Go.GoOverview, Northwoods.Go, Version=, Culture=neutral, PublicKeyToken=a4e3b7b70161cfe8

I also made sure that Build Action property on the licenses.licx file was set to “Embedded Resource.”

Once I made those two changes and Rebuilt the solution, everything worked. My application now deploys to machines without the License Manager installed and runs perfectly.

I am a happy camper.