Troubles with Silverlight4 in Firefox


I have some troubles with Firefox.

I did the steps recommended in this forum to debug Silverlight in Firefox and everything works fine. But if I use Firefox with the config as normal the content of Silverlight doesn´t show up (but in IE it shows up).

I also use SL 4 instead of 3 now. But if I “enable debugging” in Firefox it works fine. So SL4 should not be the problem. If I use your SL3-dll everything works fine, too. Just your SL4-dll with disabled debugging doesn´t work in Firefox.

Any ideas?

Or is this maybe a Silverlight-bug?



See Debugging Silverlight in Firefox 3.6.4.

Hi Walter!

With “steps recommended in this forum to debug Silverlight in Firefox” I meant your post. I considered your post. But if I do not change the about:config of Firefox I can´t see the content of Silverlight and of course I can not debug it. So do I have to tell all my customers to change their config? That can not be the right way…

Any ideas?



Btw: Sorry for my English.

So if I understand you correctly you cannot run your Silverlight 4 app in Firefox with the normal settings without debugging. But debugging it in Firefox works fine.

I cannot reproduce the problem. I have reset that internal Firefox dom.ipc.plugins.enabled.npctrl.dll variable to true and am able to see/run the Silverlight 4 demo on

Or perhaps I don’t understand by what you mean about not debugging in Firefox?

You understood me this time correctly.

I thought it might be a problem of GoSilverlight. But you are right. It works fine.

But I had luck. I just found my problem.

I had

<br /><go:Overview x:Name="myOverview" AllowDrop="True" ...> <br />

in my application. After I deleted this attribute everything works fine again. Like it used to be with SL3, with SL4 in FF with debugging or IE.

To find this it helped to use Firefox with dom.ipc.plugins…=true. To be able to debug you need to attach VisualStudio to plug-container.exe (menu Debug, Attach to Process…)

So I was able to get the Exception.

Hope this helps (and hopefully you understand my English).

Maybe its because of this:

Thank for your help Walter!