Weird link hickups when autolayout

Goodday, Im using GoJS Autolayout and its great so far, but one thing that bothers me atm and something i cant seem to fix is that the lines are not drawn properly when autolayouting.

See screenshot to know what I mean.

Configuration:

layout: $(go.LayeredDigraphLayout, {
    direction: 90,
    layerSpacing: 50,

this.diagram.linkTemplate = $(go.Link,
  {
    routing: go.Link.AvoidsNodes,
    curve: go.Link.JumpGap,
  },
  $(go.Shape),
  $(go.Shape, { toArrow: 'Standard' })
);

Is there a way to keep the lines as straight as possible and only reroute when its necessary?

thanks in advance!

Try setting https://gojs.net/latest/api/symbols/LayeredDigraphLayout.html#setsPortSpots to false.

layout: $(go.LayeredDigraphLayout, {
    direction: 90,
    layerSpacing: 50,
    setsPortSpots: false,
    . . . })

This gives almost the same result unfortunately

*edit: wrong screenshot, corrected now

I thought you wanted to fix the direction of the links coming out of “beslis” nodes.

OK, try setting the width of the nodes to be a multiple of the https://gojs.net/latest/api/symbols/LayeredDigraphLayout.html#columnSpacing, which defaults to 25. I don’t know what value you would like. Try 150 or 200. I would think that you would not want nodes to be too wide, anyway.

Still not exactly the result what I wanted, you are correct that setPortSpots fixed an issue on the ‘beslis notes’ so thats a good start, thank you for that!

My problem is the circled hickups in the line (this is with a width 150 and columnSpacing 50:

The result I wish to have:

Note that its just the circled hickups that are fixed, and another question is how to merge the 3 arrows into one.

edit: as I increase the columnwidth the ‘hickups’ get bigger.

Do all Nodes now have a width that is a multiple of the columnSpacing?

Make sure that toSpot and fromSpot are not any ...Side Spot.

I fixed it! I did what you told my with columnwidth and width, and also moved one exit port on ‘beslis’ nodes to bottom instead of left, In combination with setsPortSpots this gives the right result.
This is what I wanted, thanks a lot for your good and fast support.