Bezier curves fail when two elements are perpendicular

layout code:
‘layout’: this.$(go.LayeredDigraphLayout, {
isInitial: false,
isOngoing: false,
direction: 90,
linkSpacing: 0,
columnSpacing: 130,
layerSpacing: 250,
setsPortSpots: false,
link code:
this.myDiagram.linkTemplate = this.$(go.Link, // the whole link panel
curve: go.Link.Bezier,
curviness: 20,
adjusting: go.Link.Stretch,
toShortLength: 3,
// fromShortLength: -50,
this.$(go.Shape, // the link shape
stroke: ‘#767676’, strokeWidth: 2.5,
new go.Binding(‘points’).makeTwoWay(),
new go.Binding(‘curviness’, ‘curviness’).makeTwoWay(),

When the two elements are perpendicular, the Bezier curve doesn’t work。I don’t know how to solve this problem。

I don’t understand what you mean by “elements are perpendicular”.

Your screenshot looks good. Or did you want the right-most link not to connect with the sides of the nodes? If you didn’t want that, don’t set LayeredDigraphLayout.setsPortSpots to false.

Thanks for replying, I mean the curve property of this link doesn’t work even if I drag it

Your first screenshot shows a straight link, which looks good to me. What did you want instead?

What is the second screenshot showing, and what is the problem, and what do you want instead?

In the first screenshot ,I set the Bezier property, but it’s still straight。I don’t want it to be straight。
In the second screenshot I dragged the above straight line, but it was still a straight line。

Did you try setting the Link.curviness? I’m not sure that will get you what you want, though.

I’m sure I set Link.curviness, but it didn’t work

Sorry, that’s just how the LayeredDigraphLayout routes such links that would naturally be straight.

Ok, thank you. I’ll try another way to do this