Bigger nodes will cover/overlap the links of other nodes (jsfiddle included)

Hi goJS support team,
When we have two nodes that connect into another node, it will overlap the node. Is there a way around this issue? We want the user to be able to see where nodes are connecting to.

I’ve also attached a JSFiddle:
If you comment out line34 as to not use the linkTemplate with rounded corners, the effect is still there.

Any ideas how we can have the links show at all times?

Try setting layerName: "Foreground" on the link template.

Hi Walter, that works in the sense that we see the line now, but I was thinking more alone the lines of (no pun intended) of it avoiding the bigger node shape altogether. Do you think that is possible?

You could try setting Link.routing to go.Link.AvoidsNodes in the link template.