Disable initial animation


I’m on 1.6 and am trying to disable the inital loading animation. When my layeredDigraphLayout diagram loads it ‘fly in’ from the upper left corner to the lower right.

I came across the animationManager.isEnabled flag and tried this but it had no affect:

let myDiagram =
            $(go.Diagram, this._element.nativeElement, // must be the ID or reference to an HTML DIV
                    // start everything in the middle of the viewport
                    initialContentAlignment: go.Spot.TopCenter,
                    initialAutoScale: go.Diagram.Uniform,
                    layout: $(go.LayeredDigraphLayout, { direction: 90, layerSpacing: 10, columnSpacing: 80, setsPortSpots: false }),
                    "animationManager.isEnabled": false 

What am i doing wrong?


That should work – when I try adding:

    "animationManager.isEnabled": false

to a random sample, it no longer animates the layout.

You can instead set:

    "animationManager.isInitial": false

to just disable the animation of any initial layout.

Thanks “animationManager.isInitial”: false

was the behavior I was looking for, i must have missed that setting in the docs.