Floor planner can't update color after new floor plan

https://gojs.net/latest/projects/floorplanner/FloorPlanner.html#

I’m trying to use the floor planner and in the sample, when I go File -> New to load a blank floor plan, I drag a palette onto the diagram and try to change the color and it fails with error “Please enter a valid number”. I think it’s something to do with the NaN values for the units. I try changing them manually but still get same error. Any idea?

Hello! Thank you for reporting this, this is a bug, due to new Floorplans not being assigned a unitsConversionFactor. It will be fixed in the next release. For now, in FloorplanFilesystem.js, in the FloorplanFilesystem constructor, replace the definition for this._DEFAULT_MODELDATA to

this._DEFAULT_MODELDATA = {
    "units": "centimeters",
    "unitsAbbreviation": "cm",
    "unitsConversionFactor": 2,
    "gridSize": 10,
    "wallWidth": 5,
    "preferences": {
        showWallGuidelines: true,
        showWallLengths: true,
        showWallAngles: true,
        showOnlySmallWallAngles: true,
        showGrid: true,
        gridSnap: true
    }
};

Thanks for the quick reply. That worked!