How to prevent copy with ctrl

I have many nodes. Now the user wants to select some of these nodes. To do that he press the ctrl-key and click the nodes he want to select.

Now the problem:
Ctrl and mousemove also copies the nodes. Now when the user is selecting and by mistake move the mouse while clicking he gets a copy. To make the problem bigger - when he had grid snap enabled he isn’t even able to see that mistake cause the new nodes are covering the old ones on exact the same position.

Is it possible to disable the ctrl-mousemove copy behavior?

I think you can override the DraggingTool.MayCopy() method to return false.