Is this a GoJs or a canvas bug?

Hi there,
i’m using GoJs and i found that in some computers there is an issue with my display, so i came here to wiki page to see if i’m doing something wrong and i found out that the same thing is happening here.

I cannot find the reason it happens and i happens to some computers here but not at all, even same computers and mac :S

In my part where ever is text the it’s pitch back something like an overlay above the text. In wiki pages there is this issue and also an issue not displaying text at all.

Here’re some screenshots from your wiki page:


Any ideas?

Well, that’s very surprising. I’m sorry that you have run into this – I do not recall anyone ever having this kind of complaint. And I know we have a lot of customers.

I have no idea of what might be wrong. Maybe there’s something broken about the fonts?

On machines where the diagrams do not render correctly, are there any diagrams that do render correctly? Is the rendering of any text necessary to see the problem?

So, to get more information about this problem: you are only using http://gojs.net/latest – i.e., there isn’t an ancient version of GoJS that might be involved? What kinds of machines and operating systems and browsers exhibit the problem, and what kinds do not? (In your experience, of course.)

How long have you noticed this problem on those machines? If things had been rendering well for you before on those machines, can you characterize any changes that have happened to those machines?

I forgot to ask the standard debugging questions:

  • are you using go-debug.js?
  • are there any console messages?

Hi @walter,
yes i’m using debug version but there are no console messages.

This is so annoying :confused: i guess for you also. I must find a solution and have no idea truly now i hoped that you guys knew something about this.

If you find anything please info me.

btw: latest chrome version and firefox have the same issue (on two macs here and not in an other one. no common plugins or something even tried without any browser plugins).

Thanks for telling us that you are using the debug library but you see no console messages, and that you are using Chrome and Firefox “latest”, and that you are using Macs.

What versions of OSX are you using? Is there a difference between the machines where it does not work and the ones where it does work?

If you change your app or any of the samples to use a different font, by setting TextBlock.font in the template(s), do they render well on all of your machines?

I really would like to know how to recreate the problem. As you can guess, we have never seen any problems on the Macs that we own or that we have tried GoJS on. And I know that there are many customers who use all kinds of Macs, and I do not think we have heard about any rendering problems.

Yes i guess so. Macs have different OsX (yosemite & el capitan).
The same issue as you can see we have it in your documentation pages.
Believe me i’m trying to find something to give or something to have in hands to work with it but i can’t until now.

Hmmm. Do the El Capitan 10.11 machines exhibit the problem but the Yosemite 10.10 machines do not? I wonder if it’s somehow related to the new default San Francisco font. We can look into that, just in case that is the problem for you. But we did upgrade to 10.11 a while ago, and we didn’t notice any problems.

Do some of your machines have Retina displays and others do not?

It would be useful if you tried what I suggested – specifying a particular font in some (broken) app to see if it fixes it.

Alright Walter.
Thanks for your interest if i found anything in the next few days i’ll re-open this post.

Take care!