Issue - Link is not dragged when node is dragged

We have recently upgraded GoDiagram from 4.0 to 4.2. While testing existing applications, I have observed potential issue with Node and Link; what is happening is when I drag Node to a position other than current, corresponding link is not getting dragged accordingly. It appears that this happens with only first node and once only.
I have created sample code to illustrate this, run this sample and try to drag GoBoxNode1, you can see that link between GoBasicNode and GoBoxNode1 does not move accordingly.
This works okay with version 4.0.
Can you please help with the resolution?
Sample code
GoBasicNode basicNode = new GoBasicNode(GoFigure.Circle);
basicNode.Text = "GoBasicNode";
basicNode.Position = new PointF(50, 50);
GoBoxNode goBoxNode1 = new GoBoxNode();
goBoxNode1.Text = "GoBoxNode1";
goBoxNode1.Position = new PointF(50, 100);
goBoxNode1.LinkPointsSpread = true;
GoBoxNode goBoxNode2 = new GoBoxNode();
goBoxNode2.Text = "GoBoxNode2";
goBoxNode2.Position = new PointF(50, 150);
goBoxNode2.LinkPointsSpread = true;
GoBoxNode goBoxNode3 = new GoBoxNode();
goBoxNode3.Text = "GoBoxNode3";
goBoxNode3.Position = new PointF(150, 150);
goBoxNode3.LinkPointsSpread = true;
GoLink link1 = new GoLink();
link1.FromPort = basicNode.Port;
link1.ToPort = goBoxNode1.Port;
GoLink link2 = new GoLink();
link2.FromPort = goBoxNode1.Port;
link2.ToPort = goBoxNode2.Port;
GoLink link3 = new GoLink();
link3.FromPort = goBoxNode1.Port;
link3.ToPort = goBoxNode3.Port;

Sorry for the delay. We will look into this as soon as we can.

I don’t see a problem using 5.0, which happens to be what you’re licensed to use.

There were some changes to GoBoxNode/GoBoxPort in 4.2, but I don’t remember
changing anything after that… so I’m puzzled by that a bit.

Is there some reason you didn’t move to 5.0?


Thanks for suggestion, I have tried with version 5.0 and 5.1 both and I saw same problem with these versions too. See screenshots from both versions
Am I missing something?

We’re out for Thanksgiving, I’ll be back in the office Tuesday.

Is there anything else going on in the screenshots above, or is it exactly the code you posted above, with
no changes to Tools or GoView?


Here is what I have done
- Quickly installed new versions
- Replaced reference to GoDiagram assemblies in the test application I have created and replaced the instance of GoView appropriate to the version
- For 5.1 I have tried with Visual Studio 2010 targetting framework 4.0 and so upgraded my original test application project.
No changes have been done in the code I have pasted in previous post.

Can you send me your complete test application?

Can’t find way to attach or upload file with the forum post, is there any e-mail address I can send the test application?

Thought you had email from me… I’ve sent one just now.

ok… this is why I wasn’t seeing it.

goView1.DragsRealtime = true;

I’ve often thought we’ve had the default wrong on this. See if this is a good workaround for
you, I think you’ll like real time dragging.

Thanks for the workaround, I have tried this and it works in normal condition. However it does not solve the issue completly, if I move node around very quickly, I can still re-produce this issue with real time dragging too.

Please have a look at it.

update: a workaround for mixing GoBoxPort nodes with other nodes was provided. Let us know if

you are having this issue.