Issue with Mouse Scroll

I have implemented the GoView and am using it to statically place items. This is all working correctly. I have set the size of the godocument to be equal to that of the control itself.

When I click on an object on the control it becomes the SelectedItem. My issue is that if I use the scroll button on my mouse, it moves the whole document and the alignment is all screwed up for the document. It doesn't fire a Go... event and I cannot overwrite it. Actually the only way to recenter the items is to slowly scroll the mouse to move the document back to it's original position.
I am looking to completely control the GoView. I have disabled mouse entry, all keys as well as scroll bars.
Before I scroll:
After I scroll:

Any ideas on this?
I tried to capture the form level mouse scroll event and that didn't net any results either.
Thanks for your time.

What have you done to disable “mouse entry, all keys as well as scroll bars”?

This is the designer code for the GoView:

Me.goViewItem.AllowCopy = False
Me.goViewItem.AllowLink = False
Me.goViewItem.AllowReshape = False
Me.goViewItem.AllowResize = False
Me.goViewItem.ArrowMoveLarge = 0.0!
Me.goViewItem.ArrowMoveSmall = 0.0!
Me.goViewItem.AutoPanRegion = New System.Drawing.Size(0, 0)
Me.goViewItem.AutoScrollDelay = 10000
Me.goViewItem.AutoScrollRegion = New System.Drawing.Size(0, 0)
Me.goViewItem.AutoScrollTime = 0
Me.goViewItem.BackColor = System.Drawing.Color.WhiteSmoke
Me.goViewItem.Border3DStyle = System.Windows.Forms.Border3DStyle.Sunken
Me.goViewItem.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
Me.goViewItem.DisableKeys = CType((((((((((((Northwoods.Go.GoViewDisableKeys.ArrowMove Or Northwoods.Go.GoViewDisableKeys.CancelDeselects) _
Or Northwoods.Go.GoViewDisableKeys.SelectAll) _
Or Northwoods.Go.GoViewDisableKeys.SelectsByFirstChar) _
Or Northwoods.Go.GoViewDisableKeys.Delete) _
Or Northwoods.Go.GoViewDisableKeys.Clipboard) _
Or Northwoods.Go.GoViewDisableKeys.Edit) _
Or Northwoods.Go.GoViewDisableKeys.Page) _
Or Northwoods.Go.GoViewDisableKeys.Home) _
Or Northwoods.Go.GoViewDisableKeys.[End]) _
Or Northwoods.Go.GoViewDisableKeys.Undo) _
Or Northwoods.Go.GoViewDisableKeys.ArrowScroll), Northwoods.Go.GoViewDisableKeys)
Me.goViewItem.DragRoutesRealtime = False
Me.goViewItem.GridCellSizeHeight = 8.0!
Me.goViewItem.GridCellSizeWidth = 8.0!
Me.goViewItem.GridMajorLineWidth = 10.0!
Me.goViewItem.GridOriginRelative = True
Me.goViewItem.GridOriginX = 2.0!
Me.goViewItem.GridOriginY = 2.0!
Me.goViewItem.GridSnapDrag = Northwoods.Go.GoViewSnapStyle.Jump
Me.goViewItem.GridStyle = Northwoods.Go.GoViewGridStyle.Line
Me.goViewItem.Location = New System.Drawing.Point(8, 79)
Me.goViewItem.Margin = New System.Windows.Forms.Padding(0)
Me.goViewItem.MaximumSize = New System.Drawing.Size(867, 52)
Me.goViewItem.MinimumSize = New System.Drawing.Size(867, 52)
Me.goViewItem.Name = "goViewItem"
Me.goViewItem.ScrollSmallChange = New System.Drawing.Size(1, 1)
Me.goViewItem.ShadowHeight = 0.0!
Me.goViewItem.ShadowWidth = 0.0!
Me.goViewItem.SheetRoom = New System.Drawing.Size(0, 0)
Me.goViewItem.SheetStyle = Northwoods.Go.GoViewSheetStyle.Sheet
Me.goViewItem.ShowHorizontalScrollBar = Northwoods.Go.GoViewScrollBarVisibility.Hide
Me.goViewItem.ShowsNegativeCoordinates = False
Me.goViewItem.ShowVerticalScrollBar = Northwoods.Go.GoViewScrollBarVisibility.Hide
Me.goViewItem.Size = New System.Drawing.Size(867, 52)
Me.goViewItem.TabIndex = 1
All keys should be disabled and the scroll bars do not show up. I do process the PreviewKeyDown method, but it does not fire when the mouse wheel scrolls.
Thanks again.


To disable scrolling with the mouse wheel…
override the GoToolManager.DoMouseWheel method:

public class NoZoomToolManager : GoToolManager {
public NoZoomToolManager(GoView v) : base(v) { }

public override void DoMouseWheel() {
if (!this.LastInput.Control) base.DoMouseWheel();
If you didn't want the scroll wheel to do anything, just define DoMouseWheel as a no-op.

Install this custom tool as the default tool, and as the current one, as follows:

goView1.Tool = goView1.DefaultTool = new NoZoomToolManager(goView1);