my program based on the DynamicPorts example. When i change the Routing from Orthogonal to AvoidsNodes i have the following problem: When two nodes are connected by a link, and i manipulate the routepoints with the mouse, these points got lost, when i select all three parts and move them around. Is there a way to avoid this rerouting to the Default routing points manually? For example, reroute the link when its moved on another node and otherwise keep the custom route…

No, I believe that isn’t possible at this time.

Just to clarify, you don’t have this problem when the Routing is Orthogonal (not AvoidsNodes), do you?

No, then i dont have this problem. But than i have another abnormal behaviour: While moving the three parts, the custom route switches back to default routing randomly. It happens WHILE im moving, not after mouseUp, sometimes after 1 second of shifting sometimes after 10 seconds of shifting. Very strange. But this only happens at orthogonal routing and i cant repeat it at DynamicPorts example. The only difference between my code and the DynamicPorts example is, that im using palettes…

I’ll see if I can reproduce the problem.

I just tried this scenario and am unable to reproduce the behavior that you are seeing.

My Links have Route.Routing=“Orthogonal” and are Reshapable. After reshaping a link, dragging it along with the nodes that it connects maintains the relative route (i.e. the shape) of the link, no matter where I drop it.

Yes, I also have a Palette, but I really don’t think that should matter.

Do you have grid snapping enabled when dragging? If the both nodes aren’t initially snapped to cells, that might cause them to be re-routed because the relative position of the nodes with respect to each other might change as nodes get snapped.

Okay, i understand now. When i set GridSnapEnabled to False and Routing is orthogonal, then it works. But in my old scenario, the nodes were initially snapped so this should not causing the re-route. Maybe a bug. Thanks for help.