No shadow visible for Adornment when there is no or transparent background


I have an Adornment and if I’m not setting regular non transparent color to Adornment background, shadow props taking no effect.
What I’m doing wrong?

		background: 'transparent',
		isShadowed: true,
		shadowVisible: true,
		shadowOffset: new go.Point(0, 2),
		shadowColor: 'rgba(0, 0, 0, 0.06)',
		shadowBlur: 6,
		desiredSize: new go.Size(112, 108),
	goMake(go.Placeholder, {
		isActionable: true, // needed because this is in a temporary Layer

Note the documentation for Part.isShadowed, Part | GoJS API

The color of the shadow is determined by shadowColor. The opacity of the shadow color is multiplied by the opacity of the shadowed object’s brush. So, for example, if you have a Panel with a GraphObject.background that is “transparent”, the shadow that is drawn for the panel will also be transparent.

Hmmm, I see.

What can I do if my Adornment is of this size of main panel (red background just for debug) and its background must be transparent.
But I need this area to make tooltip stay if user moves mouse off the place which actually calles tooltip?

Dont want to tell my designers that I cant add a shadow on a tooltip :)

It looks very odd to have a shadow extend an empty area – people do not expect something invisible to cast a shadow. That’s why the shadow transparency is proportional to the transparency of the shadowed object.

Don’t set shadowVisible on the outer panel and just have the shadow be on the object(s) that are really seen by the user, by setting shadowVisible to true on those object(s).

I might explaing myself incorreclty, of course I need to add a shadow only on visible part of Adornment.

Ok… But I still need to keep props that defines shadow style on the outer panel? Since they can be set only on Part, right?

Yes, shadow style properties are only on Part. But GraphObject.shadowVisible is for each object in the Node or Link.
GraphObject | GoJS API

Ok, I think I got into another occurance of the brainfreeze, I thought I can’t set shadowVisible on shape.
Thanks a lot!