Planogrammer. How to stop grid movement?

Hello there,

In planogrammer example, when I drag the object from palette to grid area, if I drag the object in the left side of the view, the Grid is Moving right side. I’ don’t know how to stop this behaviour. Is there a way where I can stop this movement?

Appreciate your assistence on it.


Are you talking about having the GoView scroll to show more of the left side of the document? (If it can scroll more in that direction.)

That is called autoscrolling, and it should happen also when you are dragging objects within the view, inside and near the edge of the view.

A drag-and-drop from another control such as the palette will not cause an autoscroll immediately – there is a wait before it starts autoscrolling.

If you do not want to support autoscrolling, you can turn it off by setting the GoView.AutoScrollRegion property.

Or you can change the delay time by setting GoView.AutoScrollDelay.