Problem at Deployment

Hello,



we are having an issue when trying to deploy our proyect.We are trying to deploy separating dlls for each folder,had generated key licences for GoView,GoLayout and GoInstruments and put them in the Global.asax file…



We followed all steps described in DeployGoDiagram.pdf and it should be working but its not,what else can we try?



Thanks in advance,

Kind regards.

Web Application Project or Web Site Project?

Hello Jake, is a Web Application Project.



Thanks

I’m not sure what you mean by “We are trying to deploy separating dlls for each folder”… can you provide more on that?



and can you post the error you’re getting? and what version of IIS?

When u add a web deployment proyect,u can set on its properties an option to either “Merge all outputs to a single assembly” or “Merge each individual folder output to its own assembly”…We choose the second option without the optional prefix.



We are using Visual Studio 2008.



The error is:







The version of IIS is 7.0.



P/S: We were adding the web deployment proyect choosing the first option and it has been working fine,but with the second one it doesnt.



Thanks

OK… the “web deployment project” is a separately downloadable Visual Studio thing, right? Point me at where you downloaded yours so I know I’m playing with the same widgets.



I don’t see anything that mentions “GoDiagram” in that error message. What makes you think we’re the cause?

We download it from the Microsoft official page(http://www.microsoft.com/downloads/en/details.aspx?FamilyId=0AA30AE8-C73B-4BDD-BB1B-FE697256C459)



I forgot to mention that the error occurs when we try to open the page that uses the GoDiagram control…Any other pages works fine.





Can you get me the rest of the Error message that is hidden?



and this may be relevant: http://weblogs.asp.net/leftslipper/archive/2007/02/26/sys-webforms-pagerequestmanagerparsererrorexception-what-it-is-and-how-to-avoid-it.aspx



if you could read through that and look at your page to see if any bells go off.

or alternatively… add a trivial web page to your site that only has a GoView and see if that page also generates an error.



(my reading about this error implies it only happens with UpdatePanels. So if this error happens with just a GoView, some very strange is happening.)

[QUOTE=Jake] or alternatively… add a trivial web page to your site that only has a GoView and see if that page also generates an error.



[/quote]



Jake,we tried doing that and it worked(no error),so what do you suggest we do?



Maybe some problem with GoLayout?



Thanks.

Do you have an AJAX UpdatePanel in the page that fails?

Yes we do,but the page worked before with AJAX…we just only changed the way we make the web deployment proyect nothing else.

Well, that weblogs.asp.net page I gave you above lists all the reasons you might get this error when using an UpdatePanel… so I’d go look at that. Using Response.Write seemed to be one thing.



Why does it happen when you build one way and not the other? I haven’t a clue. Maybe exception handling is different?



(edited to fix typo)

In order to perform the deploys we are using Web Deployment Projects,it’s a microsoft tool , and we are handling two option to build the aplication :





1 ) When we build the deploy eith the option to merges all the output assemblies from the compiler into a single assembly, the goDiagram worked.



With this option we were copying the key genereted by the license manager, in the global.asax





2 ) But when we build the deploy with the option to creates a separate output assembly for each folder, the goDiagram did not work .



with this option we are copying the key in the codebehind of the page that contains the goDiagram control





Do you know if the goDiagram is compatible with this tool and that option to build.



Did you have any luck trying to reproduce this issue ?



Thank in Advance



Kind Regards

I downloaded the Web Deployment Project support, added it to an existing (and working) minimal Web App project. and the Web App stopped working, even without the deployment. I didn’t get past that.

Did you test it with Visual 2008,iis 7 and windows XP ? thats spooky ,

we will appreciate your help , do you know if thats fine copying the key in the codebehind of the page that contains the goDiagram control for the second choice to build the deploy, named in the before mail



Thanks.

VS2008, Vista, and the development server. As soon as I add the deployment project, I can’t even run the WebApp project.



ah… what happens is I get a build error in the deployment project: “Warning 2 Cannot find any assemblies that can be merged in the application bin folder. aspnet_merge”



So… I probably don’t have something set right, but I have no confidence right now that I could ever reproduce your problem.



If you can send me a simple project that demonstrates the issue, I’ll take a look at that.