Remove shadow above tablerow text

Hi,

I’m trying to remove shadow above text contained in a tablerow but I can’t get rid of it…
Here’s the image


As you can see the text above “S139” drop a shadow over the table background…
Here’s my code:

//NODE
      var fieldTemplate2 =
        $(go.Panel, "TableRow",  
          new go.Binding("portId", "id"),  
          {
            background: "transparent",  
            fromSpot: go.Spot.Left,  
            toSpot: go.Spot.Left,
            // allow drawing links from or to this port:
            fromLinkable: false, toLinkable: true
          },
          $(go.Shape, "TriangleRight", { 
        	  alignment: go.Spot.Left, 
        	  width: 9, 
        	  height: 9, 
        	  column: 0, 
        	  margin: 0, 
        	  fill: "#5EA9BE",
        	  fromLinkable: false, 
        	  toLinkable: true }),
          $(go.TextBlock,
            { margin: new go.Margin(0, 2), column: 1, font: "bold 12px sans-serif",
              // and disallow drawing links from or to this text:
              fromLinkable: false, toLinkable: false },
            new go.Binding("text", "name"))

        );
//TEMPLATE
        var fieldTemplate7 =
          $(go.Panel, "TableRow",  			   
            new go.Binding("portId", "name"),              {
              background: "transparent",  
              fromSpot: go.Spot.Left,   
              toSpot: go.Spot.Left,
              fromLinkable: false, 
              toLinkable: false
            },
            $(go.TextBlock,
              { margin: new go.Margin(0, 2), column: 1, font: "bold 12px sans-serif", 
            	alignment: go.Spot.Left,
                fromLinkable: false, toLinkable: false },
              new go.Binding("text", "name"))
         );

Can you help me?
Regards
Fulvio

It’s odd that you have that text shadow in your green node but not in your blue node. You must be using a different template for that node.

If after setting the Part.shadow… properties the default shadowing behavior isn’t what you want, you can fine-tune it on a per-object basis by setting https://gojs.net/latest/api/symbols/GraphObject.html#shadowVisible to false.

Hi Walter,
You’re right, here’s the part regarding the blue node. It’s a little bit different but I can’t find anything regarding shadow above text…

//NODE
      myDiagram.nodeTemplateMap.add("Startvoce",
        $(go.Node, "Auto",
    	{
    		deletable: false,
            isShadowed: true,
            shadowColor: "grey",
            shadowOffset: new go.Point(4,4)
    	},
          new go.Binding("location", "loc", go.Point.parse).makeTwoWay(go.Point.stringify),
          $(go.Shape,"RoundedRectangle",
            { fill: "#F6F6F6" }),
          $(go.Panel, "Vertical",
            $(go.Panel, "Auto",
              { stretch: go.GraphObject.Horizontal },  
              $(go.Shape,
                { 
                  fill: "#007bff", 
                  stroke: null
                }
              ),
              $(go.TextBlock,
                {
                  alignment: go.Spot.Center,
                  margin: 3,
                  stroke: "white",
                  textAlign: "center",
                  font: "bold 10pt sans-serif"
                },
                new go.Binding("text", "key"))),
            $(go.Panel, "Table",
              {
                name: "TABLE",
                padding: 2,
                minSize: new go.Size(140, 10),
                defaultStretch: go.GraphObject.Horizontal,
                itemTemplate: fieldTemplate0,
   		        cursor:"pointer"
             },
              new go.Binding("itemArray", "fields")
            )  
          )  
        ));  
//TEMPLATE
      var fieldTemplate0 =
        $(go.Panel, "TableRow",  
          new go.Binding("portId", "name"),  
          {
            background: "transparent",  
            fromSpot: go.Spot.Right,  
            toSpot: go.Spot.Right,
            fromLinkable: true, toLinkable: false
          },
          $(go.TextBlock,
                  { margin: new go.Margin(0,2), 
              	  column: 1, 
              	  font: "bold 12px sans-serif",
              	  alignment: go.Spot.Center, 
                    fromLinkable: false, toLinkable: false },
                  new go.Binding("text", "name")),
          $(go.Shape, "TriangleRight", { 
        	  alignment: go.Spot.Right, 
        	  width: 9, 
        	  height: 9, 
        	  column: 2, 
        	  margin: 0, 
        	  fill: "#5EA9BE",
        	  fromLinkable: true, 
        	  toLinkable: false })
        );

But in which GraphObject I must set the “shadowVisible” to false? in the whole panel or in the table panel…or what ? Thx
Regards
Fulvio

Set shadowVisible to false on whichever objects are causing a shadow that you don’t want.

It works!
Thx & ciao
Fulvio