[SOLVED] Diagram enabled = false and scrollbars

Hi,

I set isEnabled = false in my Diagram and the scrollbars are disabled too. Is possible disable the Diagram but not the scroolbars? Because I only want to view the big Diagram but not edited

Regards,

There are many possibilities, as described at http://gojs.net/latest/intro/permissions.html

scrollbars doesnt work with this combination

myDiagram.isEnabled= false;
myDiagram.allowHorizontalScroll = true;
myDiagram.allowVerticalScroll = true;

That’s correct. Disabling a Diagram basically causes it to ignore all keyboard/mouse/touch events.

I can use isReadOnly but contextmenu it shows

is there a property like diagram.allowContextMenu? I want to disable all the context menues of diagram. thanks

You can disable a Tool by setting Tool.isEnabled to false.

When you initialize the Diagram:

        $(go.Diagram, . . . 
            { "contextMenuTool.isEnabled": false },
            . . .)

Or just set myDiagram.toolManager.contextMenuTool.isEnabled.

but, with isReadOnly = true all the nodes are “selectables” and they show their selectionAdornmentTemplate. How can avoid this?

Diagram.allowSelect ?

You’ll want to go through all of the possibilities listed in that permissions page.