Unable to access the actual tooltip text when using a template binding

I’m attempting to do a test of tooltip text on a node. The tooltip is set up with two elements (see below), the second of which is the TextBlock. I’m accessing the text via node.toolTip.elements[1].text. What I see is an empty string text property. I can see the binding description under the property localBindings, but I don’t seem to be access the result of binding. The tooltip is actually working just fine for manual checks in the UI. but I want to be able to do it in an automated test.
The only way I can get the text property populated is by uncommenting the text line in the TextBlock definition.
How do I access the result of text derived from a binding?

	public getToolTip(fieldName: string): Object {
		return {
				this.$(go.Adornment, 'Auto',
					this.$(go.Shape, {
						fill: this.tooltipStyle.getPropertyValue('fill'),
					this.$(go.TextBlock, {
						margin: new go.Margin(6),
						font: StyleHelper.getFont(this.tooltipStyle),
						//text: "DEFAULT TEXT"
					new go.Binding('text', fieldName))
				)  // end of Adornment

Is the tooltip actually visible at the time that you evaluate: node.toolTip.elements[1].text ?

No. So the text property is only bound when the tooltip is visible?

Just tried it with a delay, and that does indeed bring up the proper text when the tooltip is visible.

The process of adding any Adornment to the Diagram will also set its data property and evaluate all of its Bindings.

As a follow up to this, when the tooltip is too long for a single line I would expect to wrap, but this isn’t happening. Looking at the docs the default is for maxLines=Infinity and wrap=TextBlock.WrapDesiredSize. I also tried wrap=TextBlock.WrapFit. I’ve also tried explicitly setting isMultiline=true and maxLines=Infinity. Is this a quirk for tooltips or is something else going on?

There needs to be some constraint on the width of the TextBlock for it to wrap if needed.