Uncaught TypeError: Cannot read property 'class' of null

Hi, Team!
I built diagram and I’m getting this error:

    Uncaught TypeError: Cannot read property 'class' of null
    at Function.Z.fromJSON.Z.fromJson (go.js:1739)
    at HTMLDocument.<anonymous> (builder.js:675)
    at j (jquery.js:3099)
    at Object.fireWith [as resolveWith] (jquery.js:3211)
    at Function.ready (jquery.js:3417)
    at HTMLDocument.I (jquery.js:3433)

I’m getting this error when I’m running “funnelDiagram.model = go.Model.fromJson(json);”.
This is model json link: https://jsonformatter.org/ca8f1a

I"m sure all other code parts are correct. In my opinion, I’m getting this error because of json data(please focus on “notes” field and you can see that includes html-formatted string with css such as font-family, font-color, height etc. This data comes from user’s copy-paste formatted string from other source into text editor that I built and user saves diagram).
But strange thing is that I get this error on Ubuntu 16.04 server only, while it works well on localhost xampp server (on Windows).
I set “MEDIUMTEXT” as datatype for model json data field in mysql db.

Please help me with this. It’s killing my time.
Regards.

That’s not valid JSON syntax.

Sorry, this is correct json data link: https://jsonformatter.org/ca8f1a
Please check and help me. Thanks.

You have the JSON starting with:

{ "class": "GraphLinksModel",

Try this instead:

{ "class": "go.GraphLinksModel",

I’m getting json data from this function:

funnelDiagram.model.toJson();

So i can’t try your suggestion manually.
So I changed json data manually in db but it didn’t work. Still i’m getting same error.
How should I resolve this issue?

Precisely which version of GoJS is this? Evaluate go.version.

Go.js version: 2.0.17
I’ve found this error occurs when there is “”" inside of json value.
I tried with go-debug.js and console says “JSON.parse error: SyntaxError: Unexpected token O in JSON at position 764”
Before “O”, there is “”".
So I think “;” is regarded as kind of full stop and “O” is recognized as Unexpected token?

The syntax for JSON is very strict. That includes how strings are quoted.
Please read http://json.org/.