Upgrading Angular project

Please help Facing below issue.

Did you just upgrade some software? If so, which software and from which version to which version?

Note that gojs-angular requires a very recent release of GoJS 2.1.

Please check below package.json file and let me know which dependencies should update.

{

“name”: “akash”,

“scripts”: {

"ng": "ng",

"start": "ng serve",

"build": "node --max_old_space_size=8192 ./node_modules/@angular/cli/bin/ng build --prod --build-optimizer",

"test": "ng test",

"lint": "ng lint",

"e2e": "ng e2e"

},

“private”: true,

“dependencies”: {

"@agm/core": "1.0.0-beta.2",

"@angular/animations": "5.2.9",

"@angular/cdk": "^5.2.5",

"@angular/common": "5.2.9",

"@angular/compiler": "5.2.9",

"@angular/core": "5.2.9",

"@angular/flex-layout": "5.0.0-beta.13",

"@angular/forms": "5.2.9",

"@angular/http": "5.2.9",

"@angular/material": "^5.2.4",

"@angular/platform-browser": "5.2.9",

"@angular/platform-browser-dynamic": "5.2.9",

"@angular/router": "5.2.9",

"@asymmetrik/ngx-leaflet": "3.0.2",

"@ngx-loading-bar/router": "1.3.1",

"@ngx-translate/core": "9.1.1",

"@ngx-translate/http-loader": "2.0.1",

"@swimlane/ngx-datatable": "11.2.0",

"@types/pdfjs-dist": "^0.1.2",

"activedirectory2": "^1.2.6",

"angular-bootstrap-md": "^6.1.6",

"angular-calendar": "0.23.7",

"angular-datatables": "^5.0.0",

"angular-tree-component": "8.3.0",

"angular2-datetimepicker": "^1.1.1",

"angular2-prettyjson": "^3.0.1",

"browserify-fs": "^1.0.0",

"chart.js": "^2.7.2",

"core-js": "2.5.3",

"crypto-js": "^3.1.9-1",

"d3": "4.13.0",

"datatables.net": "^1.10.16",

"datatables.net-dt": "^1.10.16",

"dragula": "^3.7.2",

"emailjs": "^2.2.0",

"file-saver": "^1.3.8",

"form-data": "^2.3.2",

"fs": "0.0.1-security",

"gojs": "^2.1.8",

"gojs-angular": "1.0.3",

"gulp": "^3.9.1",

"gulp-typescript": "^5.0.0-alpha.3",

"hammerjs": "2.0.8",

"install": "^0.11.0",

"intl": "1.2.5",

"jquery": "^3.3.1",

"leaflet": "1.3.1",

"moment": "2.21.0",

"ng-drag-drop": "^4.0.1",

"ng-module": "^1.0.0",

"ng2-charts": "1.6.0",

"ng2-ckeditor": "^1.2.0",

"ng2-dragula": "1.5.0",

"ng2-file-upload": "1.3.0",

"ng2-validation": "4.2.0",

"ngx-bootstrap": "^2.0.4",

"ngx-gallery": "^5.6.2",

"ngx-icon-picker": "0.0.8",

"ngx-image-zoom": "^0.6.0",

"ngx-perfect-scrollbar": "5.3.5",

"ngx-progressbar": "^2.1.1",

"ngx-quill": "2.2.0",

"ngx-spinner": "^6.0.0",

"pdfjs-dist": "2.0.943",

"primeng": "^5.2.4",

"rxjs": "5.5.7",

"screenfull": "3.3.2",

"webpack": "^3.11.0",

"webpack-cli": "^3.1.0",

"webpack-dev-server": "^3.1.6",

"xlsx": "^0.13.5",

"yarn": "^1.9.4",

"zone.js": "0.8.20"

},

“devDependencies”: {

"@angular/cli": "^1.7.3",

"@angular/compiler-cli": "^5.2.9",

"@angular/language-service": "5.2.9",

"@types/datatables.net": "^1.10.9",

"@types/jasmine": "~2.8.3",

"@types/jasminewd2": "~2.0.2",

"@types/jquery": "^3.3.1",

"@types/node": "~6.0.60",

"codelyzer": "^4.0.1",

"gulp-tsc": "^1.3.2",

"jasmine-core": "~2.8.0",

"jasmine-spec-reporter": "~4.2.1",

"karma": "~2.0.0",

"karma-chrome-launcher": "~2.2.0",

"karma-cli": "~1.0.1",

"karma-coverage-istanbul-reporter": "^1.2.1",

"karma-jasmine": "~1.1.0",

"karma-jasmine-html-reporter": "^0.2.2",

"protractor": "~5.1.2",

"ts-loader": "^0.8.2",

"ts-node": "~4.1.0",

"tslint": "~5.9.1",

"typescript": "^2.9.2"

}

}

You can look at the dependencies yourself. For example, https://github.com/NorthwoodsSoftware/gojs-angular/blob/master/package.json shows that gojs-angular currently depends on version 2.1.10 of GoJS.

Does npm update not help?